View Issue Details

IDProjectCategoryView StatusLast Update
0000840CaseTalk Viewer[All Projects] Generalpublic2016-01-14 12:06
ReporterBCP Software 
Assigned ToBCP Software 
PrioritynormalSeverityminorReproducibilitysometimes
Status resolvedResolutionfixed 
Product Version2.4.1 
Target Version2.4.2Fixed in Version2.4.2 
Summary0000840: Weak entities are not shown
DescriptionWhen a primary key consist of columns which are all foreign keys, the entity itself is considered weak. This should be displayed as a rounded rectangle.
Steps To ReproduceIn the student example the table for Preference should be considered a weak entity since it solely depends upon Project and Student.
TagsNo tags attached.

Relationships

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2016-01-14 12:06 BCP Software New Issue
2016-01-14 12:06 BCP Software Status new => assigned
2016-01-14 12:06 BCP Software Assigned To => BCP Software
2016-01-14 12:06 BCP Software Status assigned => resolved
2016-01-14 12:06 BCP Software Fixed in Version => 2.4.2
2016-01-14 12:06 BCP Software Resolution open => fixed