View Issue Details

IDProjectCategoryView StatusLast Update
0000083CaseTalk ModelerModel Transformation (GLR)public2012-05-24 12:32
ReporterBCP Software 
Assigned ToBCP Software 
PrioritynormalSeveritymajorReproducibilitysometimes
Status resolvedResolutionfixed 
Product Version6.14 
Target Version6.20Fixed in Version6.15 
Summary0000083: Solve the column name algorithm
DescriptionRole fixes are required to solve a name clash when a distinctive nominalised object is missing. The validation for model well-formedness warns for this.

In addition the GLR process can be adjusted to use the OriginalOT or a LabelType as a column name, again to solve name clashes. During this process of GLR transformation, CaseTalk attempts to resolve the role fixes and using OriginalOT where ever possible.

Despite the efforts sometimes the GLR still requires column fixes to be set manually, hence the existence of the ColumnFix-Dialog.
Additional InformationSolution:

By not simply setting the OriginalOT once during lexicalization, but simply appending all OrignalOT's, we would end up with a solid columnname. This column name is build using the full role path from the conceptual model.

The ColumnFix-Dialog would never have to be used again, since all columns are named after the conceptual role path. Only a shortening algorthm is required to generate proper DDL for a database.

Lexicalization code can be simplified much further and the outcome is far more preferable than it is currently.
TagsNo tags attached.

Relationships

related to 0000066 resolvedBCP Software CaseTalk Modeler Column fixes should be set using the "prefix" method 
related to 0000096 resolvedBCP Software CaseTalk Modeler Shortest columnnames may even be shorter 
related to 0000087 resolvedBCP Software CaseTalk Viewer ERD doesn't honor role/column fixes 

Activities

BCP Software

BCP Software

2012-05-14 12:23

administrator   ~0000053

Implemented and works great. Note, there's not backward compatibility option. This may affect already generated databases since new DDL scripts may have different column names.

Issue History

Date Modified Username Field Change
2012-05-10 13:47 BCP Software New Issue
2012-05-10 13:47 BCP Software Status new => assigned
2012-05-10 13:47 BCP Software Assigned To => BCP Software
2012-05-11 17:04 BCP Software Status assigned => confirmed
2012-05-14 12:23 BCP Software Note Added: 0000053
2012-05-14 12:23 BCP Software Status confirmed => resolved
2012-05-14 12:23 BCP Software Fixed in Version => 6.15
2012-05-14 12:23 BCP Software Resolution open => fixed
2012-05-14 14:55 BCP Software Relationship added related to 0000066
2012-05-19 15:43 BCP Software Relationship added related to 0000096
2012-05-24 12:32 BCP Software Relationship added related to 0000087
2016-01-20 12:56 BCP Software Category GLR => Transformation (GLR)
2016-01-20 13:00 BCP Software Category Transformation (GLR) => Model Transformation (GLR)