View Issue Details

IDProjectCategoryView StatusLast Update
0000817CaseTalk ModelerModel Validationpublic2016-12-15 16:46
ReporterBCP Software 
Assigned ToBCP Software 
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Product Version 
Target Version9.0Fixed in Version8.15 
Summary0000817: Split FactType with 1 UC and more than 2 roles
DescriptionFacts which are properly created according to the N-1 rule, may still contain invalid modeling. Every FactType with more than 2 roles, and a single UC (non overlapping with others) over more than 1 role, is candidate to be nominalized.

Therefor the roles under the UC should be split into a seperate ObjectType.
TagsNo tags attached.

Relationships

related to 0000461 assignedBCP Software CaseTalk Modeler Split OTFT into two 

Activities

BCP Software

BCP Software

2015-12-11 17:57

administrator  

nominalize_n-1.png (21,983 bytes)
nominalize_n-1.png (21,983 bytes)
BCP Software

BCP Software

2015-12-11 18:33

administrator   ~0000488

Question:

The new fco-im book, mentions on page 162 a violation of the N-1 Rule. Among the examples is "Employee on Project for Department". The N-1 rule violation is related to the UC6. However if the UC 4 is properly nominalised, there would be no need for this violation to be mentioned.

Therefor the question arises: Should we nominalise role 37+38 into "Project for Department", or consider this N-1 rule ineffective since it is in effect a binary fact, combining "Employee" and "Project for Department"?
BCP Software

BCP Software

2016-02-22 15:25

administrator   ~0000525

Besides the discussion for checking this, a generic functionality could be to nominalize a group of selected roles (as long as they "match").

- A group of roles within the same facttype may be selected for nominalisation
- A group of roles in multiple facttypes, should match playedbyot's, and than could be nominalised.
BCP Software

BCP Software

2016-10-24 17:49

administrator   ~0000674

Split Fact Type is now available from the menu. Precondition is that the verbalisation requires the roles under the UC to be adjacent.

Issue History

Date Modified Username Field Change
2015-12-11 14:05 BCP Software New Issue
2015-12-11 14:05 BCP Software Status new => assigned
2015-12-11 14:05 BCP Software Assigned To => BCP Software
2015-12-11 17:57 BCP Software File Added: nominalize_n-1.png
2015-12-11 18:24 BCP Software Description Updated View Revisions
2015-12-11 18:33 BCP Software Note Added: 0000488
2016-01-20 12:59 BCP Software Category Validation => Well Formednes Rules
2016-01-20 13:00 BCP Software Category Well Formednes Rules => Model Validation
2016-02-22 15:25 BCP Software Note Added: 0000525
2016-02-23 16:54 BCP Software Relationship added related to 0000461
2016-10-24 17:49 BCP Software Status assigned => resolved
2016-10-24 17:49 BCP Software Resolution open => fixed
2016-10-24 17:49 BCP Software Fixed in Version => 8.15
2016-10-24 17:49 BCP Software Note Added: 0000674