View Issue Details

IDProjectCategoryView StatusLast Update
0000791CaseTalk ModelerDiagramspublic2018-03-01 16:54
ReporterwobbenAssigned Towobben 
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Product Version 
Target Version9.0Fixed in Version8.19 
Summary0000791: Show OTFT with special icons
DescriptionThe Custom Attributes allow for special settings on OTFT's. These could be used to display special icons in the diagram.

For instance for DWH/history settings a Clock could be displayed alongside the OTFT in the diagram.

These settings via Custom Attributes could be made visual in diagrams through specialized iconsets.
TagsNo tags attached.
CaseTalk Edition

Relationships

related to 0001208 assignedwobben CaseTalk Modeler Support Status/Task in user interface 

Activities

wobben

wobben

2017-03-06 09:17

administrator   ~0000731

Perhaps we should consider using Task States:

Ready
Assigned
Terminated
Expired
Forwarded
Finished
Failed

Since we consider Fact Types to be in some sort of model-handling-state, we could consider them as individual tasks in the modeling process.
https://en.wikipedia.org/wiki/Task_management
wobben

wobben

2017-03-06 09:48

administrator   ~0000732

Last edited: 2018-03-01 16:54

View 2 revisions

Note: A maximum of 16 different icons can be programmed due to windows user interface limitations in the ListView component.

wobben

wobben

2017-03-06 10:38

administrator   ~0000733

OTFT State Icons are supported using a Custom Attribute Definition. Please create a category "Status" with an attribute "Task". This "Task" should be of type "option" with the following values:

Ready
Assigned
Terminated
Expired
Forwarded
Finished
Failed

Once the custom attribute for an otft is set to any of these values, the otft will be accompanied by a special icon indicating this state in a graphical manner.

Issue History

Date Modified Username Field Change
2015-11-17 17:04 wobben New Issue
2015-11-17 17:04 wobben Status new => assigned
2015-11-17 17:04 wobben Assigned To => wobben
2017-02-10 23:04 wobben Target Version Future => 9.0
2017-03-06 09:17 wobben Note Added: 0000731
2017-03-06 09:48 wobben Note Added: 0000732
2017-03-06 10:38 wobben Status assigned => resolved
2017-03-06 10:38 wobben Resolution open => fixed
2017-03-06 10:38 wobben Fixed in Version => 8.19
2017-03-06 10:38 wobben Note Added: 0000733
2017-03-07 10:58 wobben Relationship added related to 0001208
2018-03-01 16:54 wobben Note Edited: 0000732 View Revisions