View Issue Details

IDProjectCategoryView StatusLast Update
0002612CaseTalk ModelerGeneration (SQL, XML, etc)public2020-08-14 16:31
ReporterBCP Software Assigned ToBCP Software  
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Target Version10.2.2Fixed in Version10.2.2 
Summary0002612: ER/Studio foreign key definition column issue
DescriptionER/Studio script sometimes contains foreign key definition causing too few columns in the child table. This is due to column names which overlap where they shouldn't.
TagsNo tags attached.
CaseTalk Editionunknown

Activities

BCP Software

BCP Software

2020-08-14 16:31

administrator   ~0001719

The VB Script is extended to override the rolenames to prevent duplicates by ER/Studio (These duplicates collapse in the diagram, hiding them from view.)

For Each pair in FK<..>
  pair.ChildAttribute.RoleName = pair.ChildAttribute.LogicalRoleName
Next

Issue History

Date Modified Username Field Change
2020-07-21 09:42 BCP Software New Issue
2020-07-21 09:42 BCP Software Status new => assigned
2020-07-21 09:42 BCP Software Assigned To => BCP Software
2020-08-14 16:31 BCP Software Status assigned => resolved
2020-08-14 16:31 BCP Software Resolution open => fixed
2020-08-14 16:31 BCP Software Fixed in Version => 10.2.2
2020-08-14 16:31 BCP Software Note Added: 0001719