View Issue Details

IDProjectCategoryView StatusLast Update
0001085CaseTalk ModelerRepositorypublic2016-09-30 11:50
ReporterBCP Software 
Assigned ToBCP Software 
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Product Version 
Target Version8.14Fixed in Version8.14 
Summary0001085: Easily transform Rolefix to ObjectType
DescriptionRole fixes have a historical existence. In the conceptual model a user may reduce an object type. This will also generate a rolefix in an attempt to persist the name of the reduced object type.

Currently there's no easy way to expand existing rolefixes into an object type.

Also since the new CaseTalk with the new column name algorithms, has no use for rolefixes anymore, an easier way to promote all legacy models with rolefixes to nominalised object types would be very convenient.
TagsNo tags attached.

Relationships

Activities

BCP Software

BCP Software

2016-09-29 12:37

administrator   ~0000650

The Task menu now contains "Expand Role Fix" when a selected OTFT has roles with fixes.
BCP Software

BCP Software

2016-09-30 11:50

administrator   ~0000654

https://www.youtube.com/watch?v=kLOM6erCv0E

Issue History

Date Modified Username Field Change
2016-09-29 12:36 BCP Software New Issue
2016-09-29 12:36 BCP Software Status new => assigned
2016-09-29 12:36 BCP Software Assigned To => BCP Software
2016-09-29 12:37 BCP Software Status assigned => resolved
2016-09-29 12:37 BCP Software Resolution open => fixed
2016-09-29 12:37 BCP Software Fixed in Version => 8.14
2016-09-29 12:37 BCP Software Note Added: 0000650
2016-09-30 11:50 BCP Software Note Added: 0000654