View Issue Details

IDProjectCategoryView StatusLast Update
0001017CaseTalk ModelerUser Interfacepublic2016-07-12 11:24
ReporterBCP Software 
Assigned ToBCP Software 
PrioritynormalSeverityblockReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target Version8.11.1Fixed in Version8.11.1 
Summary0001017: 'Index out of range' when inserting OTE
DescriptionAn 'index out of range' occurs when entering a new expression and inserting an existing ObjectTypeExpression.
Steps To ReproduceWhen repository is opened with a diagram which is no longer in sync, leave the diagram disconnected. Add a new expressions, the current repository window will have nothing to show because of the disconnected diagram.

Now when pressing Ctrl+Space to insert an existing OTE, the repository window is empty and nothing can be chosen. Therefor the index error occurs.
TagsNo tags attached.

Relationships

Activities

BCP Software

BCP Software

2016-07-11 12:02

administrator   ~0000615

Workaround: Set the repository highlighting to 'active diagrams'. This prevents the repository window to hide crucial ote's.
BCP Software

BCP Software

2016-07-12 11:24

administrator   ~0000616

The feature "Insert Object Type Expression" no longer depends on the selection in the Repository Window.

Issue History

Date Modified Username Field Change
2016-07-11 12:01 BCP Software New Issue
2016-07-11 12:01 BCP Software Status new => assigned
2016-07-11 12:01 BCP Software Assigned To => BCP Software
2016-07-11 12:02 BCP Software Note Added: 0000615
2016-07-12 11:24 BCP Software Note Added: 0000616
2016-07-12 11:24 BCP Software Status assigned => resolved
2016-07-12 11:24 BCP Software Fixed in Version => 8.11.1
2016-07-12 11:24 BCP Software Resolution open => fixed